Missing reports from Google for July 31st
Incident Report for Appfigures
Resolved
The monthly re-import for July has completed for all accounts. If you're still missing data for July 31st reach out to the support team for a deeper dive.
Posted Sep 13, 2023 - 12:25 EDT
Update
Good news! Google has regenerated July reports with data for the 31st. We'll kick off a sync for all Google accounts, for July, to pick up on data for the day.
Posted Aug 31, 2023 - 11:06 EDT
Update
As of now, we are still waiting for Google to regenerate July reports with numbers for July 31st.
Posted Aug 28, 2023 - 09:53 EDT
Update
So far Google has not regenerated reports with updated data for the 31st so we're still waiting on those to be corrected. As soon as they are we'll update you here as well as re-import reports.
Posted Aug 21, 2023 - 17:07 EDT
Update
Google continues to investigate the dropped day of the 31st and also regenerate reports for all. We'll continue to monitor until the 31st is updated for all developers.
Posted Aug 16, 2023 - 11:21 EDT
Update
Google is investigating the missing data for free apps, on the 31st. Hopefully we'll have another update to share soon.
Posted Aug 14, 2023 - 10:07 EDT
Update
We're working with Google in hopes of bringing the July reports up to date with data for July 31st as soon as possible. As we have more we'll update you with the latest.
Posted Aug 10, 2023 - 13:00 EDT
Update
Still waiting on Google to update the July report with data for July 31st. We'll share anything new as soon as we've detected data has been updated.
Posted Aug 09, 2023 - 11:40 EDT
Update
We're still waiting on Google to release data for the 31st. We'll continue to monitor until then.
Posted Aug 08, 2023 - 10:07 EDT
Monitoring
A heads up - data is missing specifically for the downloadable reports whereas the dashboard may have data for the 31st. We'll import the day as soon as that is generated within Google's reports.
Posted Aug 07, 2023 - 15:46 EDT
Identified
We've found that Google's reports, covering free apps, have dropped data for the last day of the month (7/31). Data for the July report stops on July 30th. However, data is already available for August, from the 1st through the 4th. So you will see a drop in reporting on the 31st but that picks up again on August 1st.

Google's reports for paid products do not drop out on the 31st so all days are currently available in those reports, up to the 6th.

As soon as data becomes available for the 31st we will automatically import for everyone.
Posted Aug 07, 2023 - 15:40 EDT
This incident affected: Google Play (Downloads).