Keyword ranks for iOS apps aren't updating hourly
Incident Report for Appfigures
Resolved
The underlying issue has been resolved and ranks are updating normally.
Posted May 25, 2020 - 21:51 EDT
Investigating
We are investigating an issue where keyword ranks from the App Store aren't updating for some members
Posted May 25, 2020 - 19:55 EDT
This incident affected: ASO.