Apple Report Delays for July 18th
Incident Report for Appfigures
Resolved
Apple reports for the missing period have been imported and reports from App Store Connect continue to be available for following days without issue.

If you're missing any reports between July 18th and July 22nd reach out to the support team for a closer look.
Posted Jul 25, 2024 - 09:54 EDT
Update
Some good news! Apple resolved their issue with exporting reports for the 18th and on. We're in the process of importing all reports, sales and subscriptions, that were delayed during the last few days.
Posted Jul 23, 2024 - 09:35 EDT
Update
Apple's issues continue to impact downloading reports via Sales and Trends Reports with data as of July 18th. As soon as we learn more, we'll share those updates here.
Posted Jul 22, 2024 - 10:15 EDT
Update
App Store Connect outage remains and reports starting on the 18th and on are still unavailable for downloading, without errors. We've reached out to Apple and will continue to monitor until reports are available to import.
Posted Jul 21, 2024 - 12:19 EDT
Update
Reports are still unavailable as errors remain in Sales and Trends Reports. We'll continue to keep an eye on this one!
Posted Jul 20, 2024 - 18:02 EDT
Update
Apple's errors continue as reports for the 18th and 19th are not available for downloading. These errors impact sales reports as well as subscription reports.
Posted Jul 20, 2024 - 14:32 EDT
Update
We're continuing to wait for Apple to release reports. So far a small number of accounts have seen new reports but only a few. We're continuing to monitor this situation.
Posted Jul 19, 2024 - 19:51 EDT
Monitoring
App Store Connect is experiencing issues with downloading sales reports for July 18th through Sales and Trends. Although data is available in the dashboard, it is not available for download so we can't import it.

We're actively monitoring the situation and we'll automatically import new reports once Apple resolves the issue.
Posted Jul 19, 2024 - 12:41 EDT
This incident affected: Apple (Downloads & Revenue).