Delays updating Featured data
Incident Report for Appfigures
Resolved
We resolved the underlying issue and ensured featured data is now up to date for all apps and games.
Posted May 31, 2021 - 13:21 EDT
Identified
We're working to resolve and issue that's causing featured data to not update for 5/31
Posted May 31, 2021 - 12:57 EDT