Delays with Google's Reporting for Free App Data
Incident Report for Appfigures
Resolved
Google has now released reports covering free app data up to and including 9/28. All auto-importing accounts will automatically pick up those missing days.

Since the current delay (the 29th and 30th) is in line with Google's usual delay of a couple days we're resolving the delayed incident.
Posted 22 days ago. Oct 01, 2019 - 09:12 EDT
Monitoring
Google is currently delayed with releasing reports after 9/23 as reports have only been made available up to an including the 23rd. We're keeping an eye on this delay and we'll import reports as soon as they are detected.
Posted 23 days ago. Sep 30, 2019 - 09:28 EDT
This incident affected: Google Play (Downloads).