Steam imports are back up and running. We’ve been monitoring the latest fix over the past 24 hours and everything looks good. If anything still appears behind, feel free to reach out to support for a closer look.
Posted Apr 01, 2026 - 09:26 EDT
Identified
We implemented what we believed would resolve the Steam import issue, but it hasn’t fully worked as expected. We’re taking another look and will share updates as we learn more.
Posted Mar 31, 2026 - 08:13 EDT
Update
We’re still investigating issues impacting the import of Steam data. We’ll share updates as we learn more.
Posted Mar 30, 2026 - 14:03 EDT
Investigating
We’re currently investigating issues impacting the import of Steam data. We’ll share updates as we identify the root cause and work to restore syncs as quickly as possible.