Google Subscription Delays

Incident Report for Appfigures

Update

Subscriptions are still delayed after November 26th as we wait for Google to release additional days of data. We'll continue to monitor from our end.
Posted Dec 11, 2025 - 11:01 EST

Update

We're still waiting on Google to release additional days of subscription reports. Right now, the latest date available in the reports remains November 26th.
Posted Dec 09, 2025 - 08:35 EST

Monitoring

Google hasn’t released subscription data (Active Subs, Activations, Cancellations) since Nov 26, which is a longer delay than usual. Revenue is still up-to-date since it comes from the sales report.

As soon as Google publishes the missing data, we’ll automatically pull it in for everyone.
Posted Dec 08, 2025 - 11:13 EST
This incident affects: Google Play (Subscriptions).