Competitor Paid Keywords report errors

Incident Report for Appfigures

Resolved

All clear - the Competitor Paid Keywords report is back to normal.
Posted Feb 10, 2026 - 13:32 EST

Monitoring

Things are settling down with the Competitor Paid Keywords report. Errors are subsiding, and we’re keeping an eye on it.
Posted Feb 10, 2026 - 09:40 EST

Investigating

We’re seeing errors in the Competitor Paid Keywords report. The team is investigating and will share updates here as we learn more.
Posted Feb 10, 2026 - 09:24 EST