Google's Delay for Free Apps

Incident Report for Appfigures

Resolved

Google continues to work with a delay of releasing reports, about a five day delay. This seems to be the new normal for free apps. We'll continue to keep an eye on it and hopefully returns to the past release schedule which was closer to three days.
Posted Dec 17, 2024 - 12:32 EST

Update

Reports through the 19th are now available from Google.
Posted Nov 24, 2024 - 17:50 EST

Update

Google has released additional days of data, now available up through the 17th of November. The existing delay continues to be longer than normal so we'll continue to monitor release times.
Posted Nov 22, 2024 - 09:16 EST

Update

We're still waiting on Google to release monthly reports with data after the 11th, for free apps.
Posted Nov 20, 2024 - 10:37 EST

Monitoring

November 11th is the latest date available in monthly reports, released by Google, adding up to a lengthy delay in data for free app. Google however, has updated data in their dashboard, but not in the monthly reports available for importing.

We're reaching out to Google about the delay and we'll automatically import additional days after the 11th as those become available.
Posted Nov 19, 2024 - 09:43 EST
This incident affected: Google Play (Downloads).