Google Play Subscription Discrepancies
Incident Report for Appfigures
Resolved
Good news - the Google subscription re-import for May and June has completed and numbers should look much better. If you're still seeing any subscription data that looks off, send an email to support at support@appfigures.com for a closer look.
Posted Jun 28, 2022 - 13:17 EDT
Monitoring
We've rolled out a workaround for changes to Google's subscriptions reports and are re-importing May and June for everyone.
Posted Jun 28, 2022 - 08:54 EDT
Update
After another look at what's available from Google, we've found that Google's subscription reports are reporting most countries, but not all, in two rows as opposed to the usual one row per country for each day.

We don't know if this change is permanent or temporary, so in the meantime we'll see if we can introduce a workaround to handle the current report as is.
Posted Jun 27, 2022 - 18:37 EDT
Identified
After a deeper dive, what we've found is that Google's exportable reports, that we import (Download reports > Statistics), have been amended on Google's end. The data in Google's developer dashboard however, remains as it was previously reported - with no drop at the start of the month.

We'll see if we can get more clarity on the exportable reports, from Google, and go from there.
Posted Jun 27, 2022 - 15:16 EDT
Investigating
We're investigating recent reports of discrepancies with Google's Active Subscriptions beginning on June 1st. As it's still early in the investigation we don't have too much to report right now however, we'll share more as we learn more!
Posted Jun 27, 2022 - 12:45 EDT
This incident affected: Google Play (Subscriptions).