Low revenue reporting from Google starting March 15th
Incident Report for Appfigures
Resolved
Google has confirmed a billing issue that left many payments on March 15th and 16th in a "chargeable" state for the two days and were processed on subsequent days of the 17th and 18th.

With this, numbers for those four days are correct on Google's end.

You'll see lower revenue numbers on the 15th and 16th and the following days higher revenue as those in the "chargeable" state were successfully processed.
Posted Mar 31, 2023 - 11:41 EDT
Update
So far, Google hasn't made any changes to revenue reports for March 15th or 16th. We'll continue to monitor for any changes within Google's March reports.
Posted Mar 28, 2023 - 09:42 EDT
Update
Google revenue numbers from March 15th and 16th continue to look low. Numbers however, do match what Google is reporting in both their downloadable reports (which we use) and the developer dashboard.

We'll continue to monitor and see if Google releases any updates, if so those changes will be picked up on automatically.
Posted Mar 24, 2023 - 19:16 EDT
Monitoring
Google has released revenue data, in the dashboard again, up to March 20th.

Revenue for the 15th and 16th continues to look low for developers however, reports in the dashboard and downloadable reports are reporting the same numbers.

We'll continue to monitor numbers from Google and if reports are updated for those days we'll automatically import those numbers.
Posted Mar 22, 2023 - 10:35 EDT
Identified
After investigating member reports of low revenue, from Google, on March 15th and March 16th, we believe that Google is experiencing issues reporting revenue.

While revenue for the 15th and 16th is available in downloadable reports, which we use, the data seems to be low for many developers. Revenue seemingly returns to normal again on the 17th, from these same downloadable reports.

Revenue after March 14th is unavailable through Google's developer dashboard.

We'll continue to monitor from our end and we'll automatically import regenerated reports as soon as they are available from Google.
Posted Mar 20, 2023 - 16:02 EDT
This incident affected: Google Play (Revenue).