Issues with Google Play verification
Incident Report for Appfigures
Resolved
We're confidentially resolving the earlier incident related to Google's verification changes after performing additional testing for newly linked accounts.

Any account that previously had trouble linking or re-linking should now be able to successfully link once again.

Please reach out directly if you need help getting linked.
Posted Apr 21, 2020 - 17:36 EDT
Identified
We've rolled out several updates, but are aware of some accounts that are still unable to verify with Google. We are continuing to work to get all members to be able to verify reliably and apologize for how long this is taking.
Posted Apr 12, 2020 - 18:32 EDT
Update
After closely monitoring the fixes we pushed earlier, we're still working to resolve the verification updates for some members. We'll continue to report any new updates for those accounts here.
Posted Apr 07, 2020 - 18:34 EDT
Monitoring
We've rolled out an update that resolves the issue and will allow all newly linked accounts to verify with Google. We'll be monitoring linking to ensure there are no additional issues.
Posted Apr 06, 2020 - 18:07 EDT
Update
We've traced the root cause of this issue to a change on Google's end, and are in the process of testing a temporary workaround as well a permanent solution.

We understand the importance of this integration and are working to get linking back to full working order as fast as we can. We'll continue to update this incident as new updates are available.

Please note, this does not impact accounts that are already syncing.
Posted Apr 05, 2020 - 16:18 EDT
Identified
We're continuing to work to resolve the issue when connecting/re-linking Google Play accounts. As soon as more information becomes available we'll share with you here.
Posted Apr 03, 2020 - 10:04 EDT
Investigating
We've investigating an issue impacting the verification process across a handful of Google Play accounts. As a result, you may run into trouble when attempting to add a new Google Play account or re-link an existing account.

The integration team is working to resolve this as quickly as possible. We will look to share updates as they become available.
Posted Apr 02, 2020 - 10:00 EDT
This incident affected: Google Play (Downloads, Revenue).