Amazon Review Delays
Incident Report for Appfigures
Resolved
Amazon reviews are importing slowly, less often than before, but importing. We'll continue to monitor the import process with Amazon as reviews import every couple of days - we''ll also be working towards a long term solution to bring back daily imports.
Posted Oct 11, 2024 - 10:23 EDT
Identified
Amazon reviews are still struggling to import even with our newest fix. We'll need to spend additional, dedicated time to stabilize importing reviews from the store.

As more information becomes available on another workaround we'll share that here.
Posted Sep 30, 2024 - 11:08 EDT
Monitoring
Amazon reviews are actively importing once again. We'll continue to keep an eye on this fix for a bit longer to make sure this process remains stable.
Posted Sep 26, 2024 - 10:37 EDT
Update
We have a new workaround ready to go and are running some additional tests before releasing the fix goes live.
Posted Sep 24, 2024 - 18:22 EDT
Identified
We're still struggling to import Amazon reviews after the fix from last week. We'll spend more time looking for another fix to bring in up to date reviews.
Posted Sep 23, 2024 - 11:06 EDT
Monitoring
We've rolled out a fix to begin importing Amazon reviews again and are monitoring from our end.
Posted Sep 20, 2024 - 11:37 EDT
Identified
We've identified the root cause of the delay and are working on a resolution. More news to come as we get closer to a fix.
Posted Sep 19, 2024 - 14:56 EDT
Investigating
We're investigating delays importing reviews from Amazon, starting on September 18th.
Posted Sep 19, 2024 - 10:06 EDT
This incident affected: Amazon (Reviews).