There's nothing new from Google just yet. Subscription reports are still only available through August 9, and we're waiting for Google to release the following days.
We're continuing to monitor and will update here as soon as new reports become available.
Posted Aug 18, 2026 - 09:10 EDT
Monitoring
Google Play subscription reports are currently delayed, with the latest available data from Google being August 9.
The delay is on Google's side, and we're monitoring for new reports as they become available.
We'll share an update here once Google resumes releasing subscription data.
Posted Aug 17, 2026 - 14:10 EDT
This incident affects: Google Play (Subscriptions).