Delays Importing Google Reviews
Incident Report for Appfigures
Resolved
Google reviews continue to import as expected! Reach out to support directly if you're still seeing anything that looks off.
Posted Jun 09, 2022 - 15:27 EDT
Monitoring
We've rolled out an update to speed up Google review imports and are monitoring the process.
Posted Jun 09, 2022 - 12:24 EDT
Identified
We've identified the cause of the slow importing process for new reviews and are working to roll out a fix.
Posted Jun 08, 2022 - 15:21 EDT
Investigating
We're investigating reports of a potential delay importing some new reviews from Google.
Posted Jun 08, 2022 - 12:09 EDT
This incident affected: Google Play (Reviews).