General Data Delays with App Store Connect
Incident Report for Appfigures
Resolved
Good news! Apple's report release times have slowly returned to normal over the last few days and we believe that this trend should continue going forward.

We'll continue to monitor reports from our end though we're happy to finally have this resolved!
Posted Nov 26, 2019 - 13:09 EST
Update
Earlier today Apple released daily reports for the 19th bringing reports as up to date as possible. Hopefully this trend continues and release times begin to return to normal over the next few days.

We'll continue to monitor until we're confident delays have fully subsided.
Posted Nov 20, 2019 - 16:06 EST
Update
Apple's weekly email reports for 11/11 through 11/17 have not yet been released by Apple, so those are still delayed.

Also experiencing delays are the daily sales reports as reports for the 16th are currently the latest available reports.

Quick note: the Sales and Trends dashboard in App Store Connect is reporting updated data for the 17th and 18th. We'll wait for the raw reports to be generated and automatically import those once detected.
Posted Nov 19, 2019 - 10:08 EST
Update
We're still seeing delays with report release times from Apple, we'll continue to keep an eye on this until fully resolved.
Posted Nov 18, 2019 - 15:06 EST
Update
Apple just released weekly reports, which normally come in on Monday. We’ve started importing them for all accounts. Expect your weekly email report soon.
Posted Nov 14, 2019 - 08:05 EST
Update
Apple's delays continue to persist day to day . We'll continue to monitor these delays until they subside.
Posted Nov 13, 2019 - 17:21 EST
Monitoring
We've been seeing data delays from App Store Connect for the last week now, which are impacting all sales report types (daily, weekly, monthly, financial, payments). These delays are also reflected in App Store Connect's dashboard.

At this time there isn't much we can do other than to monitor closely and import new data as it becomes available.

Ranks, review, ratings, and features aren't impacted by this issue and continue to update normally.
Posted Nov 11, 2019 - 10:38 EST
This incident affected: Apple (Downloads & Revenue).