ASO Reports Not Loading

Incident Report for Appfigures

Resolved

This incident has been resolved.
Posted May 02, 2025 - 16:59 EDT

Monitoring

All ASO reports are back up and running! We'll be set going forward - we will continue to monitor for the remaining hour out of caution.
Posted May 02, 2025 - 15:29 EDT

Investigating

We're investigating errors in several ASO reports, including Inspector and Keyword Performance.
Posted May 02, 2025 - 15:20 EDT
This incident affected: ASO.