All Windows products have been re-imported for up-to-date data through May 11th. If you continue to see delays between April 26th and May 11th, contact the support team for a closer look.
Posted May 13, 2025 - 09:24 EDT
Monitoring
The update to reflect the changes from Microsoft is out. We're syncing for all Windows products, any paid product will have up-to-date data soon, if not already.
Posted May 12, 2025 - 19:34 EDT
Update
After an unannounced change from Microsoft, we've found a workaround to import reports for paid Windows products. We're working to release this update now. We'll kick off a sync for all Windows apps as soon as that's rolled out.
Posted May 12, 2025 - 17:08 EDT
Identified
Due to an issue on Microsoft's side, there are delays in generating Windows reports for paid products dated after April 26th. Microsoft's Earnings reports are not loading properly, and as a result, we are unable to generate reports beyond the 26th.
Once Microsoft resolves the issue, we will automatically update the delayed data for all members.