Email delays
Incident Report for Appfigures
Resolved
This incident has been resolved.
Posted Apr 12, 2023 - 18:15 EDT
Monitoring
We've fixed this issue and are continuing to monitor it as emails catch up.
Posted Apr 12, 2023 - 15:49 EDT
Investigating
We are currently investigating an issue preventing reports, alerts, and account management emails from being sent.
Posted Apr 12, 2023 - 15:01 EDT
This incident affected: Analytics and Alerts & Email Reports.