Google Play Download Delays

Incident Report for Appfigures

Update

Google has now released download data through March 21.

We’re still seeing a slight delay, which is unusual, so we’ll keep monitoring until things are fully caught up.
Posted Mar 25, 2026 - 12:55 EDT

Identified

We’re seeing a delay in Google Play download data from March 20 onward. Updates are still coming through fine and are up to date through March 23.

This is stemming from Google’s side, so we’re keeping an eye on it and waiting for the missing days to be released. We’ll update here as soon as things catch up.
Posted Mar 24, 2026 - 12:48 EDT
This incident affects: Google Play (Downloads).