Review delays
Incident Report for Appfigures
Resolved
Reviews are back up to speed once again.
Posted Aug 05, 2020 - 09:07 EDT
Update
We are continuing to work on a fix for this issue.
Posted Aug 04, 2020 - 15:56 EDT
Identified
We've tracked down the issue impacting reviews and are looking to push out an update as soon as possible.
Posted Aug 04, 2020 - 13:42 EDT
Investigating
Amazon and Apple reviews are importing slowly. We're investigating the delay and will provide additional details as they become available.
Posted Aug 04, 2020 - 12:05 EDT
This incident affected: Amazon (Reviews) and Apple (Reviews).