Google's Reports for Free Apps Delayed After 2/18
Incident Report for Appfigures
Resolved
Google has recently released reports, for free apps, up to an including February 25th. The current delay of two days is standard to Google's normal delay (averages two to three days). As remaining reports become available we'll automatically import them for all accounts.
Posted Feb 28, 2022 - 10:31 EST
Update
Google reports, covering free apps, are still delayed after the 18th. We'll continue to monitor until reports are released.
Posted Feb 25, 2022 - 09:53 EST
Monitoring
Google's reports covering free apps have a standard delay of two to three days. Currently, reports are not available after the 18th of February, adding to the normal delay.

Reports covering paid products are available up to the 23rd.

Once remaining reports are released from Google we'll import for all accounts automatically.
Posted Feb 24, 2022 - 08:05 EST