Elevated loading issues for all-time stats
Incident Report for Appfigures
Resolved
The rollout has gone smoothly and while we expect a few issues as the caches load we haven’t seen any real issues so we’re closing this incident.

If you run into any issues with loading reports please contact us directly via the site.
Posted Nov 01, 2022 - 01:23 EDT
Monitoring
We're making changes to speed up all-time stats reporting. In the short term, this update is expected to cause a few more errors than normal as it propagates to all accounts.

This should resolve itself quickly and after ensure all-time stats load more quickly and consistently.

We're monitoring the rollout to ensure there are no additional issues, but if anything looks weird on your end please get in touch through the site.
Posted Oct 31, 2022 - 16:16 EDT