Product Look Ups

Incident Report for Appfigures

Resolved

This is behind us and all product searches will run successfully going forward.
Posted Aug 13, 2024 - 15:00 EDT

Monitoring

Product searches are available once again, through all routes mentioned. For now, we'll keep an eye on this one to ensure everything continues as is.
Posted Aug 13, 2024 - 13:02 EDT

Update

In addition, the Competitors report is also included. We're working to bring this functionality back as quickly as possible.
Posted Aug 13, 2024 - 12:51 EDT

Identified

We've identified an issue impacting searching for public products impacting Competitor Keywords and Explorer. A fix for this will be out shortly!
Posted Aug 13, 2024 - 12:44 EDT
This incident affected: Explorer.