Issues linking Steam accounts
Incident Report for Appfigures
Resolved
All is well with Steam verification again after monitoring for the last few hours. If you are still running into any oddities reach out to the support team for a closer investigation.
Posted Aug 02, 2023 - 18:20 EDT
Monitoring
An update has been rolled out to handle Steam verification, more reliably, going forward. Anyone having trouble adding a new account or refreshing an existing account should now be able to run through the flow without issue. We'll continue to monitor for a bit longer to ensure all remains this way.
Posted Aug 02, 2023 - 13:51 EDT
Update
We continue to explore a permanent workaround for adding new Steam accounts as well as re-connecting existing accounts.

In the meantime, if you're having trouble with either route, reach out to support and we'll see if we can manage a temporary solution.
Posted Aug 02, 2023 - 09:19 EDT
Identified
We've identified a Steam issue which impacts adding new Steam accounts, as well as re-verifying existing accounts. We're looking into workarounds in the meantime and will share more once we have anything new.

In the meantime, reach out to the support team if you're having trouble for a deeper dive.
Posted Aug 01, 2023 - 16:36 EDT
This incident affected: Steam (Sales).