Google Play Subscription Delays
Incident Report for Appfigures
Resolved
Google has now released subscriptions reports up to and including March 26th. Partial reports for days after the 26th have been released as well. We'll continue to update subscriptions reports as they continue to become available for recent days.
Posted Mar 30, 2020 - 12:02 EDT
Update
We are continuing to monitor for any further issues.
Posted Mar 29, 2020 - 12:44 EDT
Update
Google's subscription reports are still delayed after the 18th of March. We're monitoring reports and will import each report as it becomes available.
Posted Mar 27, 2020 - 09:30 EDT
Update
Google Play has now released subscription reports for the 17th and 18th of March. We are still waiting for additional reports to be released for the 19th and on. We'll continue to monitor until those are generated.
Posted Mar 24, 2020 - 15:01 EDT
Monitoring
The latest Google subscription reports are available up to and including March 16th. There's quite a delay with no reports after this day having been released so far.

We'll continue to monitor the delay and reports will automatically be imported as they are made available from Google.
Posted Mar 23, 2020 - 14:17 EDT
This incident affected: Google Play (Subscriptions).