Sales report delays for free Google apps after October 4th
Incident Report for Appfigures
Resolved
Report release times from Google, for free apps, are returning to normal as data is available up to the 15th of October. Google generally releases reports two to three days delayed so this current schedule matches the expected one.

We'll keep an eye on reports for the next few days to be safe though looks like Google is back on track.
Posted Oct 18, 2024 - 10:32 EDT
Update
Reports from Google now include data up to and including October 14th.
Posted Oct 17, 2024 - 14:24 EDT
Update
Google has not released data for October 12th and on, as the latest date available in reports remains the 11th.
Posted Oct 16, 2024 - 11:46 EDT
Update
Google downloads are available through October 11th. Everyone is still waiting on Google to release data for dates from the 12th and on.
Posted Oct 15, 2024 - 12:08 EDT
Update
Good news! Earlier today Google released data, for free apps, up to and including October 11th. We'll import automatically for those days as well as when additional days are released.
Posted Oct 14, 2024 - 09:23 EDT
Update
Google has still not updated monthly reports with data after the 4th of October.
Posted Oct 13, 2024 - 18:57 EDT
Update
Still waiting for Google to update the October report with data after the 4th.
Posted Oct 12, 2024 - 16:52 EDT
Monitoring
Google is behind schedule with releasing sales data as the latest date available in downloadable reports, for free apps, is October 4th. Downloads are not available for any dates after the 4th. As soon as any additional days are released we'll import for everyone.

Data may be available in the developer dashboard where we import based on the downloadable reports. We'll monitor for any new days Google makes available.
Posted Oct 11, 2024 - 10:33 EDT
This incident affected: Google Play (Downloads).