Delays with App Store Connect Usage

Incident Report for Appfigures

Monitoring

Usage syncs are back up and running after we implemented a workaround earlier this week. We'll be keeping an eye on things throughout the rest of the day to make sure everything continues updating normally.
Posted Jun 26, 2026 - 10:35 EDT

Identified

We've located the root cause of the issue and traced it to a recent change from Apple.

We're now working on a workaround and will have usage data caught up as soon as possible. We'll share another update once syncs are back up to date.
Posted Jun 24, 2026 - 11:20 EDT

Investigating

We're currently investigating delays with usage data syncing from App Store Connect.

Usage data is delayed starting June 15. We're looking into the cause and will share another update once we have more information and syncs are caught up.
Posted Jun 22, 2026 - 18:13 EDT
This incident affects: Apple (Usage).