Ranks remain stable after monitoring for some time.
Posted Mar 17, 2025 - 18:38 EDT
Monitoring
We'll continue to monitor ranks for a bit longer, though all errors have cleared.
Posted Mar 17, 2025 - 17:38 EDT
Identified
Errors with the ranks report have mostly subsided. However, we're continuing to work on alleviating remaining sporadic errors through the site and API.
Posted Mar 17, 2025 - 15:57 EDT
Investigating
We're investigating errors in the ranks report both on-site and through the API.
Posted Mar 17, 2025 - 14:27 EDT
This incident affected: Apple (Ranks) and Google Play (Ranks).