Regenerated Subscription Reports from Google
Incident Report for Appfigures
Resolved
We've re-imported Google Play subscriptions reports which were released by Google. Your numbers may have changed with Google's re-release specifically between March 26th and March 31st.
Posted May 14, 2020 - 13:30 EDT
Identified
We've identified data within Google's subscription reports between March 26th and March 31st have been regenerated. We're in the process of re-importing subscription reports for those days.

We'll update you here once the re-import with Google has completed.
Posted May 06, 2020 - 13:49 EDT