Google Play Featured Delayed For 2019-09-05
Incident Report for Appfigures
Resolved
Google Play Featured data for 2019-09-05 has been fully imported and we don't anticipate any issues going forward. Feel free to contact Appfigures support if you have any questions.
Posted 13 days ago. Sep 05, 2019 - 22:47 EDT
Investigating
Google Play featured data is delayed for 2019-09-05. We are investigating the cause and will update this status page when we have more information.
Posted 14 days ago. Sep 05, 2019 - 07:41 EDT
This incident affected: Google Play (Featured).