Subscription Delays from Google after 9/13
Incident Report for Appfigures
Resolved
Subscription reports are now available up to and including September 20th which is within Google's standard subscription delay. We'll continue to import any new days as data becomes available.
Posted Sep 24, 2021 - 14:06 EDT
Update
Subscriptions have been released up to and including the 17th. Additional reports will import as they are made available.
Posted Sep 23, 2021 - 10:35 EDT
Update
Subscription reports from Google are now available up to and including September 15th. Syncs will automatically pick up on newly released dates.
Posted Sep 22, 2021 - 11:47 EDT
Update
There are no changes regarding subscription reports from Google. The latest day of full data continues to be September 13th.
Posted Sep 21, 2021 - 14:32 EDT
Monitoring
Google subscription reports are currently available up to and including the 13th, with partial data for the 14th. Reports after these days have not yet been released on Google's end.

We'll automatically import for all accounts as remaining as those are made available.
Posted Sep 20, 2021 - 12:02 EDT
This incident affected: Google Play (Subscriptions).