Issues syncing with Steam
Incident Report for Appfigures
Resolved
Steam has resolved their issues from last week and we've kicked off syncs for all accounts. If anything still looks off reach out to the support team from a closer look.
Posted Jun 13, 2022 - 09:35 EDT
Identified
After a thorough investigation, the sync troubles look to tie back to an issue from Steam's side. We've already reached out to Steam and we will keep an eye on this until resolved.
Posted Jun 09, 2022 - 16:31 EDT
Update
Not much new info to share so far - we continue to investigate the issue with Steam syncs.
Posted Jun 09, 2022 - 13:24 EDT
Investigating
We're currently investigating an issue that's preventing some members from syncing Steam accounts.
Posted Jun 09, 2022 - 09:34 EDT
This incident affected: Steam (Sales).