Elevated Explorer Errors

Incident Report for Appfigures

Resolved

Explorer remains stable and accessible for everyone.
Posted Nov 04, 2025 - 14:32 EST

Monitoring

Explorer is back up and running for everyone as errors have subsided. We'll continue to monitor to ensure stability.
Posted Nov 04, 2025 - 11:30 EST

Investigating

We're investigating errors throughout Explorer, making Explorer inaccessible to members. We're working to identify the root cause and bring it back as quickly as possible.
Posted Nov 04, 2025 - 11:26 EST
This incident affected: Explorer.