Google Account Sync Issues

Incident Report for Appfigures

Resolved

We've been monitoring things closely, and all Google accounts are now importing normally again.

Keep in mind that Google has its own issue where downloads are not available after June 17th, and subscriptions are not available after June 14th. Hopefully that's resolved on Google's end soon and we're monitoring it in a separate status page incident.
Posted Jun 26, 2026 - 10:20 EDT

Monitoring

Google account syncs are back up and running as usual, and any accounts affected by today's issue should now be updating normally.

We're monitoring as syncs catch up for the day.
Posted Jun 25, 2026 - 15:01 EDT

Investigating

We're looking into an issue that popped up earlier today and is preventing a number of Google accounts from syncing.

We're investigating the root cause now and will post another update as soon as we know more.
Posted Jun 25, 2026 - 11:15 EDT
This incident affected: Google Play (Downloads, Subscriptions).