Reviews Report Not Loading

Incident Report for Appfigures

Resolved

The reviews report is stable and will continue to remain as so!
Posted Apr 12, 2024 - 11:12 EDT

Monitoring

The reviews report is back up and running again - we'll continue to monitor for a bit longer to ensure all remains.
Posted Apr 11, 2024 - 10:33 EDT

Investigating

We're investigating performance issues with the Reviews report for most members. For those impacted, you'll have trouble loading the reviews, as well as review counts.
Posted Apr 11, 2024 - 10:29 EDT
This incident affected: Amazon (Reviews), Apple (Reviews), and Google Play (Reviews).